|    |    |    | Today: 20-Sep-2017 |

IBM OpenAdmin Tool SOAP welcomeServer PHP Code Execution

August 22, 2017 | Posted in ExploitAlert

This Metasploit module exploits an unauthenticated remote PHP code execution vulnerability in IBM OpenAdmin Tool included with IBM Informix versions 11.5, 11.7, and 12.1. The 'welcomeServer' SOAP service does not properly validate user input in the 'new_home_page' parameter of the 'saveHomePage' method allowing arbitrary PHP code to be written to the config.php file. The config.php file is executed in most pages within the application, and accessible directly via the web root, resulting in code execution. This Metasploit module has been tested successfully on IBM OpenAdmin Tool 3.14 on Informix 12.10 Developer Edition (SUSE Linux 11) virtual appliance.


Source: IBM OpenAdmin Tool SOAP welcomeServer PHP Code Execution

Taged in: Exploit